Skip to main content
Help center
Start typing for instant answers...
Back to website
Contact Support
Sign in
Mattermost Knowledge Base
Self-Managed
Self-Managed
Troubleshooting for on-prem deployments.
General
Messages Incorrectly Sent to Previous Channel During Rapid Channel Switching
Single video attachments not visible when image previews are collapsed (v11.10.0)
Elasticsearch Startup Failure Causes Memory Leak and Repeated OOM Kills (v11.7+)
LDAP/SAML Nickname Attribute Exceeding 64 Characters Causes "Invalid Nickname" Login Error
Server Fails to Start After Upgrade Due to Read Replica Lag During App Migrations
Restricting Team Email Invitations to Team Administrators Only
See all 41 articles
CLI & MMCTL
Notification logs stop being produced after upgrading to Mattermost v11
Plugin fails to activate with "An account with that email already exists" for its bot account
mmctl Fails With a Credentials Error, and Deactivated AD/LDAP Users Keep Reactivating
Troubleshooting: Migrating a User from GitLab OAuth to SAML in Mattermost
Troubleshooting Guide: Delays in Managing Personal Access Tokens in Mattermost
Delete old archived channels
See all 7 articles
Licensing
Eligibility for Mattermost Staging/Testing Licenses
How to Resolve the "Invalid Signature" Error in Mattermost when requesting a Trial License
Updating a Mattermost Enterprise License
Infrastructure and Monitoring
Bulk indexing fails with HTTP 403 after migrating from Elasticsearch to OpenSearch
Investigating a Suspected Plugin Memory Leak and Capping Server Memory Growth
ARM64 support for Mattermost Server
Elasticsearch Startup Failure Causes Memory Leak and Repeated OOM Kills (v11.7+)
Data Retention Job Fails with Permission Denied on File Deletion
Enabling Korean (CJK) Search with OpenSearch/Elasticsearch in Multi-Pod Deployments
See all 42 articles
SAML Integration
SAML SSO with Entra ID: Resolving Signature Verification Errors
Solving "Duplicate Username" SAML Login Warning in Mattermost
AD and LDAP Integration
LDAP-Managed Users Cannot Be Deactivated from System Console or API (v10.2.0+)
Hiding the "Switch to Email and Password" Sign-In Option for AD/LDAP-Only Deployments
AD/LDAP Group Sync Does Not Promote Members to Team Admin
LDAP User Remains Deactivated After Returning - AuthData Mismatch on IdAttribute Change
Understanding LDAP `objectGUID` Encoding in Mattermost
LDAP Configuration Troubleshooting in Mattermost (Bind & Sync)
See all 11 articles
Plugins
Investigating a Suspected Plugin Memory Leak and Capping Server Memory Growth
Boards Attachments Invisible After MySQL to PostgreSQL Migration
Plugin Configurations Wiped in HA Environments When Plugin Subsystem Is Disabled and Re-enabled
Jira Plugin Sends Duplicate Assignment Notifications in High Availability Environments
Google Drive Plugin Notifications Not Arriving After Enabling Create/Upload Features
AI Services List Is Empty After Upgrading from Mattermost Agents v1 to v2
See all 15 articles
Return to top
Can't login, AD/LDAP setup, Server troubleshooting